GDB on ARM

Yao Qi yao@codesourcery.com
Wed Apr 2 06:22:00 GMT 2014


On 04/02/2014 01:34 PM, Ashoka K wrote:
> I cross compiled ncurses5-dev library by giving install path same as
> the path obtained by printing "arm-none-linux-gnueabi-gcc
> --print-sysroot". But still i get the same error. Also copied the
> compiled libtermcap.a  in to the same directory mentioned. Still i get
> the same error. I tried with static library, do i need to build shared
> lib or any thing else has to be done ?
> Also set variable LD (for host) as the path to the lib directory where
> libtermcap.a is copied.
> 
> checking for iconv declaration... install-shextern size_t iconv
> (iconv_t cd, char * *inbuf, size_t *inbytesleft, char * *outbuf,
> size_t *outbytesleft);
> checking for library containing waddstr... no
> configure: WARNING: no enhanced curses library found; disabling TUI
> checking for library containing tgetent... no
> configure: error: no termcap library found

You still need to make sure your installed libncurses can be found
during configure.  I build native mips gdb on x86-linux and installed
ncurse to MIPS_NCURSES.  I pass the following to configure

CFLAGS="-I$MIPS_NCURSES/include -L$MIPS_NCURSES/lib"

-- 
Yao (齐尧)



More information about the Gdb mailing list