debugging arm executable with gdb

Attila Csosz csosz77@gmail.com
Thu Apr 18 05:22:00 GMT 2013


Hi,

I have compiled linux kernel with arm-eabi toolchain on Ubuntu. The
kernel is working. Now I'd like to debug it with gdb.
I tried this command: arm-eabi-gdb vmlinux

My questions:
Which gdb should I use?
There is a gdb in the arm-eabi (downloaded with android) toolchain. This
will good?
I have tried that but I have got Don't know how to run. Try "help
target" error message.

I tried to set breakpoint to __init_begin, this works but when I tried
to start the debug with *start, run, cont* I have got this error
message.

attila@attila-desktop:~/Upload$ arm-eabi-gdb vmlinux
GNU gdb (GDB) 7.1-android-gg2
This GDB was configured as "--host=x86_64-linux-gnu --target=arm-elf-linux".
Reading symbols from /home/attila/Upload/vmlinux...(no debugging
symbols found)...done.
(gdb) break __init_begin
Breakpoint 1 at 0xc0008000
(gdb) load vmlinux
You can't do that when your target is `exec'
(gdb) start
Function "main" not defined.
Make breakpoint pending on future shared library load? (y or [n]) n
Starting program: /home/attila/Upload/vmlinux
Don't know how to run.  Try "help target".
(gdb) cont
The program is not being run.
(gdb) run
Starting program: /home/attila/Upload/vmlinux
Don't know how to run.  Try "help target".



More information about the Gdb mailing list