GDB unable to trace xchat on linux

mancha1@hush.com mancha1@hush.com
Tue Apr 16 23:10:00 GMT 2013


On Tue, 16 Apr 2013 18:08:34 -0400 "Sergio Durigan Junior" 
<sergiodj@redhat.com> wrote:
>On Tuesday, April 16 2013, mancha1@hush.com wrote:
>
>> To reproduce:
>>
>> $ gdb /path/to/xchat
>> (gdb) r
>>
>> xchat starts but hangs at "Looking up <insert server used 
>here>".
>
>What do you mean by "hangs"?  Is it unresponsible?  Can you still 
>issue
>commands on it?  Is it just waiting for the server to respond?
>

By "hangs" I mean it doesn't progress beyond "Looking up...". I am
still able to navigate the menus and open pop-ups say via "About"
menus, etc. while in this state. However, it becomes totally
unresponsive if I Server->Disconnect or XChat->Quit.

>> xchat's faq (http://xchat.org/gdb/) suggests GDB has trouble 
>debugging 
>> when a server hostname is used. As they suggest, I ran a local 
>ircd and 
>> used 127.0.0.1. The problem remains.
>
>The page doesn't suggest that.  It only suggests that you use the
>server's IP address directly.  Anyway, have you tried that?  You 
>could
>try freenode's IP address (84.240.3.129) and see if it works.
>

I understood the FAQ. I ran an ircd locally to speed up my
debugging. No numeric IP works (freenode or otherwise).

To make this crystal clear: no connection progresses beyond the 
"looking up..." message: not hostname not IP, not local, not
remote, nor any permutations thereof.



More information about the Gdb mailing list