Request change name of function lookup_enum in libbabeltrace to make GDB use this lib

John Gilmore gnu@toad.com
Thu Dec 6 10:51:00 GMT 2012


I suggest that it's best if both GDB and Libbabeltrace change the name
of lookup_enum.  That way you'll be able to compile any version of GDB
with any version of libbabeltrace (fixed or unfixed) and all four
combinations will work except "unfixed GDB" and "unfixed
libbabeltrace").

If you just change it in the library, gdb stops building on machines that
have the old library.

If you just change it in GDB, older gdb's won't be compatible with
newer libraries.  Hmm, but older gdb's don't link with that library
anyway.  So you might as well just fix it in GDB; that works for all
cases.

	John



More information about the Gdb mailing list