[RFC] "actionpoints"?

Frank Ch. Eigler fche@redhat.com
Sat Jan 16 13:51:00 GMT 2010


Stan Shebs <stan@codesourcery.com> writes:

> [...]
> Although we've been doing the overloading for a long time, it's really
> abusing our terminology, and has to be confusing to users.

Would a new *single* term for the variety of possibilities make the
situation less confusing?

> It turns out there is a generic term available - "actionpoint".  [...]

In systemtap, we use the term "probe point" to identify a place (in
code) or a time (asynchronous event).  What happens at those points --
tracing or modifying variables or whatnot -- is programmable, and
distinct from how the probe point was named.

> A plus is that the term is sufficiently vague that it is sensible
> for watchpoints, catchpoints, tracepoints, breakpoints, and the rest
> of the menagerie, including future ideas we haven't thought of yet.
> [...]

This does not sound like a plus to me.  A good term is *clear*.


- FChE



More information about the Gdb mailing list