[gdb-7.1] 10 days to branching...

Kai Tietz ktietz70@googlemail.com
Wed Feb 3 08:20:00 GMT 2010


2010/2/2 Christopher Faylor <cgf-use-the-mailinglist-please@sourceware.org>:
> On Tue, Feb 02, 2010 at 05:02:11PM +0100, Kai Tietz wrote:
>>2010/2/2 Chris Sutcliffe <ir0nh34d@gmail.com>:
>>>> I don't know - I had never heard of anyone doing this kind of build
>>>> before: ?From what I can tell, you are building a MinGW debugger using
>>>> a cygwin compiler. ?If no one answered, it's probably because no one
>>>> has anything to say (including: "that ought to work"). ?Have you tried
>>>> using a MinGW compiler instead?
>>>
>>> For the mingw-w64 build, I did indeed build from within Cygwin using
>>> the mingw-w64 cross compiling toolchain provided by the mingw-w64
>>> project. ?For the MinGW32 binary I built it using MSYS and the MinGW
>>> compiler. ?In both cases this is the method I used to the build the
>>> 7.0.1 binary.
>>
>>Yes, I can confirm that buiding on a cygwin host by a valid
>>cross-compiler is working nicely. I justed tried, and for me it still
>>works. Possibly an issue about passed configure options?
>>
>>Just one point I found today. The new break-point handling seems to
>>have problems in certain ways for me (at least on win32 versions). I
>>get in case of setting breakpoints in Obj-C always the assertation
>>'set_raw_breakpoint: Assertation sal.pspace != NULL' failed'. This is
>>new and is somehow related to recent enhancements to breakpoint
>>handling.
>
> I don't see anything like this when setting breakpoints in a c++
> app.  I'm not familiar with objective-C but I believe I managed to
> build a simple hello world app.  I set a breakpoint in main with
> no problem.
>
> This is with a i686-cygwin gdb built on linux.
>
> cgf
>

Hallo Christopher,

well for basic Object-C apps, I don't see the issue, too. For C and
C++ I couldn't reproduce this. This seems to happen on setting of
breakpoint on Object-C methods in shared object.
I tried two different ways to set breakpoint. First variant is before
starting (as pending breakpoint). This works a long as the DLL isn't
loaded. As soon as it is, the gdb gives the above mentioned
asseration. Second variant is, starting application and stopping it by
Crtl-C, setting breakpoint. Here the problem is shown directly.
I can provide the application I have (it is an about 50MB binary) and
owned by the company I am working, but it seems that in such scenario
the pspace remains NULL.

Thanks for you trying,
Kai

-- 
|  (\_/) This is Bunny. Copy and paste
| (='.'=) Bunny into your signature to help
| (")_(") him gain world domination



More information about the Gdb mailing list