gdb crashes in Cygwin

Mike Ady mike.ady2@gmail.com
Sun Oct 12 13:41:00 GMT 2008


Hi,

I apologize for posting to this forum.  I tried the Cygwin forum, and
I got no response.

I am attempting to help the author of the giac/xcas program to solve
some problems that occur only on Cygwin.  According to the author,
"Giac/Xcas is a free computer algebra system for Windows, Mac OS X and
Linux/Unix."  The author works primarily on Linux, and I use his
program on Windows/Cygwin, hence the need for my help.

The program, running on its own, doesn't crash.  However, when I try
to run the program from gdb, gdb crashes.

I have read the part of the gdb manual dealing with bug reports, and I
have read "http://www.gnu.org/software/gdb/bugs/" but I can't yet
fulfill all of the requirements for submitting a bug report.  Can
anyone provide some advice on how to proceed?

The crash is repeatable.  It occurs while the program is initializing
but after main is called, and I am able to set a breakpoint at the
last statement executed by the program before the crash.  (It's a
simple call to "gettimeofday".)  A half dozen steps later (into the
Cygwin DLL), gdb crashes.

I have configured the Cygwin core dump routine "dumper.exe" to get a
crash dump.  The dump is over 50 megabytes.  (Indeed, the program
itself is over 50 megabytes.)  I have even tried to use gdb to analyze
the crash dump, but gdb crashes doing that too, (with the command line
"gdb /usr/bin/gdb.exe gdb.exe.core").

I have downloaded the latest version of the gdb sources and I have
built it.  It exhibits all of the same behavior:

$ /usr/local/bin/gdb
GNU gdb (GDB) 6.8.50.20081012-cvs
...
This GDB was configured as "i686-pc-cygwin".

Here is my environment information (I'm running Cygwin on Windows XP SP3):

$ uname -a
CYGWIN_NT-5.1 WHISTLER 1.5.25(0.156/4/2) 2008-06-12 19:34 i686 Cygwin

$ gcc -v
Reading specs from /usr/lib/gcc/i686-pc-cygwin/3.4.4/specs
Configured with:
/usr/build/package/orig/test.respin/gcc-3.4.4-3/configure --verbose
--prefix=/usr --exec-prefix=/usr --sysconfd
ir=/etc --libdir=/usr/lib --libexecdir=/usr/lib
--mandir=/usr/share/man --infodir=/usr/share/info
--enable-languages=c,ada,c++,d
,f77,pascal,java,objc --enable-nls --without-included-gettext
--enable-version-specific-runtime-libs --without-x --enable-libgcj
 --disable-java-awt --with-system-zlib --enable-interpreter
--disable-libgcj-debug --enable-threads=posix --enable-java-gc=boehm
 --disable-win32-registry --enable-sjlj-exceptions
--enable-hash-synchronization --enable-libstdcxx-debug
Thread model: posix
gcc version 3.4.4 (cygming special, gdc 0.12, using dmd 0.125)

$ gdb
GNU gdb 6.8.0.20080328-cvs (cygwin-special)
...
This GDB was configured as "i686-pc-cygwin".

Is there anything else that I can/should do to tie this down a little better?

Thanks

Mike Ady



More information about the Gdb mailing list