GDB Focus Group at the 2008 GCC Summit

Daniel Jacobowitz drow@false.org
Thu Jul 3 12:35:00 GMT 2008


On Thu, Jul 03, 2008 at 12:26:30AM -0300, Thiago Jung Bauermann wrote:
> On Mon, 2008-06-23 at 09:15 -0600, Tom Tromey wrote:
> > Our consensus was to use the function-like syntax (second example
> > above) and to parse the arguments as expressions.  This does mean
> > there is a namespace issue, but we reasoned that we could make all the
> > standard functions have a "gdb_" prefix or something like that.
> 
> What about using a different symbol, such as '%' instead of the '$' used
> for convenience variables?

I'd like them to be convenience variables (which is what Tom has
implemented).  Putting them in the same namespace is a
well-established tradition and is how Python behaves - plus it lets
them behave transparently like inferior function pointers, which can
also be assigned to convenience variables.

Here's a suggestion: $builtin, like the bash 'builtin' builtin (can't
believe I just wrote that sentence).  That would let us recover any
lost functions.  Well, they aren't really built-in, so maybe some
other name.  The idea of having two names for each, one more
convenient and the other more robust.  WDYT?

-- 
Daniel Jacobowitz
CodeSourcery



More information about the Gdb mailing list