New branch created for "available features" support
Jim Blandy
jimb@red-bean.com
Fri Mar 3 22:36:00 GMT 2006
So a "feature" would be something like "SSE", or "MMX" with the
additional SSE registers, and then a "feature set" would be something
like "Pentium MMX" or "Pentium 3", referring to the appropriate
individual feature sets?
I understand why you want to supply base register numbers in feature
sets, rather than features; it makes it possible to share features.
But if we're going to have other sorts of features as of yet
unimagined, they may or may not expect a base register number as a
parameter. That is, you've tied something specific to register banks
to your <feature> entities.
I'd say, rename <feature> to <register-set>. Introduce new,
appropriately named kinds of entities for new kinds of features. That
way, you can look at the tag and know what sorts of parameters it
expects.
More information about the Gdb
mailing list