Return to Reverse Execution

Michael Snyder msnyder@redhat.com
Fri Jan 6 04:28:00 GMT 2006


Eli Zaretskii wrote:
>>Date: Wed, 04 Jan 2006 13:00:31 -0800
>>From: Michael Snyder <msnyder@redhat.com>
>>CC: Johan Rydberg <jrydberg@virtutech.com>,         "Frank Ch. Eigler" <fche@redhat.com>,         Dave Brolley <brolley@redhat.com>, Eric Bachalo <ebachalo@redhat.com>
>>
>>So here is my proposed gdb user interface.
>>   1) A set of new commands that mimic the existing ones,
>>   to include:
>>	reverse-step (rs)
>>	reverse-next (rn)
>>	reverse-continue (rc)
>>	reverse-finish (rf)
> 
> 
> May I raise again the issue of names?  That is, could we please
> consider
> 
> 	back-step
> 	previous
> 	back-continue
> 	back-finish
> 
> ?  I think ``reverse'' is ambiguous: it doesn't actually say that we
> are going backwards, just that we are reversing the direction, like
> some kind of toggle.  Reverse would be okay if we had some global
> direction flag which ``reverse'' command would reverse.  This is not
> the case: these commands will _always_ go backwards, even if we
> implement exec-direction and the user sets it to `backward'.

Eli, I'm certainly willing to consider it, but as I review the
previous discussion, it seems like you were the only proponant
of these names.

I do like "previous", perhaps as a synonym or alias.
Come to that, alias-commands are easy, we could always
add these names as alternatives.

Anybody else feel that "back" or "backward" is a better prefix
than "reverse"?  Or perhaps that the syntax should be implemented
as a true command prefix?  With perhaps both alternatives allowed?






More information about the Gdb mailing list