better name for var_integer et.al.
Andrew Cagney
cagney@gnu.org
Wed Sep 15 18:05:00 GMT 2004
Hello,
GDB has the variable types:
/* Unsigned Integer. *VAR is an unsigned int. The user can type 0
to mean "unlimited", which is stored in *VAR as UINT_MAX. */
var_uinteger,
/* Like var_uinteger but signed. *VAR is an int. The user can type 0
to mean "unlimited", which is stored in *VAR as INT_MAX. */
var_integer,
/* ZeroableInteger. *VAR is an int. Like Unsigned Integer except
that zero really means zero. */
var_zinteger,
I think calling something "integer" or "unsigned integer" but then not
allowing the value zero is just plain weird.
Would anyone have better names for the first two?
Andrew
More information about the Gdb
mailing list