[patch/rfc] How to handle stepping into an unresolved plt entry?
Randolph Chung
randolph@tausq.org
Mon May 24 18:52:00 GMT 2004
> Anyway, can the IN_SOLIB_RETURN_TRAMPOLINE be moved up as well (with an
> additional ecs->stop_func_name != NULL check?
I don't think checking the stop_func_name is correct; some trampolines
can be named. For example on hpux the export stubs are named. On both
hppa-linux and hpux there is a $$dyncall stub which is named.
randolph
--
Randolph Chung
Debian GNU/Linux Developer, hppa/ia64 ports
http://www.tausq.org/
More information about the Gdb
mailing list