``abnormal frame'' attribute?

Andrew Cagney cagney@gnu.org
Wed Apr 28 16:20:00 GMT 2004


I've been looking over various unwind code and one thing I've noticed is 
that code is often using:
	frame_relative_level < 0 || frame_type != NORMAL_FRAME
as a way to detect, for want of a better name, an ``abnormal frame'' 
(i.e., non-call frame).

- any suggestions on a better predicate name
- any problems with me going through and cleaning this up

on a related note, giving sentinel frames their own type will also 
simplify the logic.


More information about the Gdb mailing list