gdb-6.1: Invalid or unsupported encoding (sparc-sun-solaris2.8)

Thomas Kemmer tkemmer@hyperwave.com
Wed Apr 21 15:04:00 GMT 2004


Hi all,

I just downloaded and compiled gdb-6.1 for Solaris 2.8 (Sparc); I
can't debug any of my Solaris binaries, since I get one of the
following errors (depending on the binary):

../../gdb/dwarf2-frame.c:1111: internal-error: Invalid or unsupported encoding

../../gdb/dwarf2-frame.c:1081: internal-error: Unsupported encoding: DW_EH_PE_indirect

I also installed gdb-6.1 on several Linux boxes, and it works just
fine; I use gcc-3.2.3 on all platforms, mostly C++.  Any ideas?

Kind regards,

- Thomas



More information about the Gdb mailing list