"struct target_ops" -> "struct gdbtarg" || "struct target"

Andrew Cagney ac131313@redhat.com
Thu Oct 9 13:51:00 GMT 2003


> Hello,
> 
> The current "target_ops" structure appeared with GDB 4.  The original implementation containing only methods.  Since then the target_ops have evolved to include data vis:
> 
>     struct section_table
>      *to_sections;
>     struct section_table
>      *to_sections_end;
> 
> I think, the vector should be re-named to "struct target" or "struct gdbtarg" (consistent with gdbarch, and more name space proof) so that it correctly reflects its current implementation.
> 
> I'd like to do this now, before the target methods start being explicitly parameterized with their target vector.

I should note that an alternative is to have "struct gdbarch" as the 
object and "struct target_ops" as the methods vis:

	struct target
	{
	  .. data elements ...;
	  const struct target_ops *ops;
	};

Andrew




More information about the Gdb mailing list