the global symbol table
David Carlton
carlton@math.stanford.edu
Mon Sep 30 13:08:00 GMT 2002
On Wed, 25 Sep 2002 16:52:20 -0400, Elena Zannoni <ezannoni@redhat.com> said:
> I wonder if rewriting the symbol table is really necessary in order
> to provide namespace support.
Now I'm starting to wonder if it's a good idea, too: I just noticed
'block_found', which throws a monkey wrench into some of my ideas.
Sigh. Maybe it really would be wisest to get namespace support
working first.
While trying to understand lookup_symbol_aux, I've cleaned it up a bit
(in order to eliminate duplicate code, etc.); I'll probably submit
patches for those, since I think they'll make it easier to maintain
the function in the future. But, for now, I'll hold off on any more
serious changes.
David Carlton
carlton@math.stanford.edu
More information about the Gdb
mailing list