[RFA] Replace strdup with xstrdup in tic30-dis.c
Hans-Peter Nilsson
hp@bitrange.com
Wed Nov 27 16:44:00 GMT 2002
On Wed, 27 Nov 2002, Alan Modra wrote:
> On Tue, Nov 26, 2002 at 03:29:36PM -0800, Ian Lance Taylor wrote:
> > I tend to think that bfd_boolean is better because it makes the code
> > slightly more self-documenting. An int variable might hold any value,
> > but a bfd_boolean variable is clearly intended to hold only a true or
> > false value.
> > But I'm hardly fanatical about it.
>
> Nor am I. :) So far, it's two people for "bfd_boolean", one for
> "int".
One more for "int" here. I agree that a boolean type has its
advantages in theory for clarity, but IMO the effects have now
proved to be a net negative, a maintenance burden. Let's just
stick to "int".
brgds, H-P
More information about the Gdb
mailing list