pseudo registers in the regcache

Richard Earnshaw rearnsha@arm.com
Fri May 17 09:31:00 GMT 2002


> > How about renaming the 68k stuff as being MEMORY_REGS and reserving the 
> > PSEUDO concept for what we really seem to want -- a view of a (or a 
> > combination of) physical (or memory) register(s)?
> 
> Or update mc68hc11 :-)

Well, I was hoping to avoid something that would be regarded as a majorly 
invasive change (and which I've no chance of testing).  Reclassifying the 
mc68hc11 pseudos as memory registers would avoid that (basically it would 
be a search and replace type operation ;-).

R



More information about the Gdb mailing list