gdbserver and multithreaded programs

Dan Kegel dkegel@ixiacom.com
Fri Jun 14 19:17:00 GMT 2002


Ankur Sheth wrote:
> We tried out today's cvs on a simple remote multithreaded program on
> x86, ppc405 and sh4.  
> 
> Results :
> 	x86 - worked fine.
> 	ppc405 - worked on single threaded program, but on multithreaded
>       program output zillions of 
> 		Ignoring packet error, continuing...
> 		Ignoring packet error, continuing...
> 	as soon as we tried to step thru main.
> 
> 	sh4 - worked fine on single threaded program, but on
>       multithreaded program it output the following message.
> 		Program received signal SIG32, Real-time event 32.

I should mention we are running Linux 2.4.16 or so,
using gcc3.0.2 (gcc2.9.7 from Montavista had same problem on sh4),
and we configured once for target powerpc-unknown-linux-gnu
and in a different copy of the tree for sh-unknown-linux-gnu.

Thanks very much to Daniel J. and Montavista for contributing
these patches.  We're really looking forward to using them.

- Dan



More information about the Gdb mailing list