Problem compiling gdb and insight under cygwin

Sixtus Lee
Fri Jun 8 19:17:00 GMT 2001

Thanks! That worked. In fact all I needed to do was to switch the order of
the includes in the sim_call.c file to include defs.h before string.h. I
thought this might be a safer kludge. But I don't really know...


-----Original Message-----
From: IGOR LURI [ ]
Sent: Friday, June 08, 2001 2:50 AM
To: 'Sixtus Lee'
Subject: RE: Problem compiling gdb and insight under cygwin

To solve this problem yuo must to coment out the line 70 of string.h.

	-----Mensaje original-----
	De:	Sixtus Lee []
	Enviado el:	viernes, 08 de junio de 2001 3:30
	Asunto:	Problem compiling gdb and insight under cygwin


	Help needed...
	Compile fails for gdb-5.0 as well as insight-5.0 (same error) when I
try to
	compile under cygwin (CYGWIN_NT-5.0 1.1.8(0.34/3/2) . Compiler is
	2.95.3-2. I was building the powerpc cross-compiler. I followed the
	instructions as described on . (I was
able to
	successfully build the same thing on a Linux system).

	The configure command used was:
	mkdir -p /tmp/build/gdb
	cd /tmp/build/gdb
	/src/gdb/insight-5.0/configure --target=powerpc-eabi \
	      --prefix=/tools \
	      --exec-prefix=/tools/H-i686-pc-cygwin \
	      -v 2>&1 | tee configure.out

	The configure command used was:
	make -w all install CC='gcc -mwin32' 2>&1 | tee make.out

	I also tried:
	1. building gdb-5.0.
	2. Prefixing configure with CC="gcc -mwin32" (i.e., CC="gcc -mwin32"

	The (error) message from compile that failed is listed below:

	CLINE -DHAVE_DEVZERO     -I. -I/src/gdb/gdb-5.0/sim/ppc
	pc/../../include -I../../bfd -I/src/gdb/gdb-5.0/sim/ppc/../../bfd
	b -I
	In file included from /src/gdb/gdb-5.0/sim/ppc/sim_calls.c:43:
	/src/gdb/gdb-5.0/sim/ppc/../../gdb/defs.h:60: conflicting types for
	/usr/include/string.h:70: previous declaration of `strsignal'
	make[2]: *** [sim_calls.o] Error 1
	make[2]: Leaving directory `/tmp/build/gdb/sim/ppc'
	make[1]: *** [all] Error 2
	make[1]: Leaving directory `/tmp/build/gdb/sim'
	make: *** [all-sim] Error 2
	make: Leaving directory `/tmp/build/gdb'

	I noted there were previous mails on this subject however none were
	in resolving my problem. All help appreciated. Thanks.


More information about the Gdb mailing list