trying to make gdbserver running on intel

Frank Haverkamp f.haverkamp@web.de
Wed Jun 6 04:58:00 GMT 2001


Hi,

I want to use gdbserver on the embedded platform I am working with.
But first I wanted to try it out on my intel box. I am running Redhat 7.1
gdb and used the sources of gdb-5.0. I build the gdbserver
on my system and finally I tried to make it run on my local computer.
I wrote a testprogram and started gdbserver as following:

$ gdbserver localhost:2345 ./text

Afterwards I started gdb and typed in the following commands:

(gdb) target cisco localhost:2345

So far so good. The gdbserver said:

Process ./test created; pid = 8584
Remote debugging using localhost:2345

GDB said:

(gdb) target cisco localhost:2345
Remote debugging using localhost:2345

... and the (gdb) prompt did not return as I expected it to do. I can
type in some characters but my programm seems to be stuck at this
place.

So I tried to start gdbserver in combination with strace:

$ strace gdbserver localhost:2345 ./test

and now I can see that the stuff I type in my gdb window is
actually transfered to the gdbserver:

fcntl64(4, F_SETFL, O_RDONLY|O_ASYNC)   = 0
write(2, "Remote debugging using localhost"..., 38Remote debugging using localhost:2345
) = 38
read(4, "Hello ", 8192)                 = 6
read(4, "World!\r", 8192)               = 7
read(4,

Does anybody know what I did wrong or how this should be if it works
correctly?? Any help would be appreciated!

Thanks,

Frank


--
Frank Haverkamp
f.haverkamp@web.de
______________________________________________________________________________
Ferienklick.de - Jede Menge Urlaub auf einen Blick!
Hier geht's zu Ihrem Traumstrand: http://ferienklick.de/?PP=2-0-100-105-1



More information about the Gdb mailing list