Port to x86-64

Andrew Cagney ac131313@cygnus.com
Fri Apr 6 12:23:00 GMT 2001


Jiri Smid wrote:
> 
>   Hi,
> 
> Andreas Jaeger <aj@suse.de> writes:
> 
> > >
> > >     o       submit the configury mess early
> > >
> > >             even if you don't have real code
> > >             could I suggest thinking about
> > >             separating this out so that
> > >             you can get on with the real
> > >             work.
> > >
> 
>   Before I will submit the configury mess I would like to little discuss
> about it.
>   The generic name of CPU is x86_64 in already ported software. It seems
> that there shoud be create new config directory gdb/config/x86_64. But
> this processor is extended i386 architecture and many parts of code will
> be the same as in i386.
>   I think that the best solution is to create this new config directory
> x86_64 and from tm-x86_64.h include i386/tm-i386.h and redefine some
> declarations. What do you think?

What convention, if any, was adopted by GCC and what do config.guess /
config.sub return?

I suspect that ``x86-64'' is going to be more acceptable than x86_64 a
file name.

	Andrew



More information about the Gdb mailing list