RFC: UI_OUT activation time
Fernando Nasser
fnasser@cygnus.com
Thu Nov 16 06:37:00 GMT 2000
I am aware of several projects on the net that rely on the output
produced through the new ui_out output functions.
The separation between the CLI and libgdb also relies on that.
Currently, the old version of the code (using the ?printf_* family of
functions) is still there, on a "ifdef", but it is still the default.
One has to explicitly build with UI_OUT defined to use the new code.
The people who are working on the projects above (that includes me) are
concerned that the default has not yet been changed. This is probably
also delaying the availability of script languages in GDB.
Having both codes make the sources hard to read because of the ifdefs.
Furthermore, we cannot write code that assumes that ui_out is present
because GDB can still be configured without it. I have recently received
a patch which would change only the old code (as it is the active one)
without changing the new ui_out based version. And the ui_out code is
not been tested at large.
I propose (and I will submit a patch) to make the ui_out code the default
effective immediately, and the complete elimination of the old style code
from the sources before 5.1.
--
Fernando Nasser
Red Hat Canada Ltd. E-Mail: fnasser@redhat.com
2323 Yonge Street, Suite #300
Toronto, Ontario M4P 2C9
More information about the Gdb
mailing list