[binutils-gdb] x86: Replace AddrPrefixOp0 with AddrPrefixOpReg

sergiodj+buildbot@sergiodj.net sergiodj+buildbot@sergiodj.net
Mon May 7 17:23:00 GMT 2018


*** TEST RESULTS FOR COMMIT 75c0a438994f00240ecd1baca3e3c11cc3b219e5 ***

Author: H.J. Lu <hjl.tools@gmail.com>
Branch: master
Commit: 75c0a438994f00240ecd1baca3e3c11cc3b219e5

x86: Replace AddrPrefixOp0 with AddrPrefixOpReg

This patch replaces AddrPrefixOp0 with AddrPrefixOpReg to indicate that
the size of register operand is controlled by the address size prefix.
This will be used by Intel MOVDIRI and MOVDIR64B instructions later.

gas/

	* config/tc-i386.c (process_suffix): Check addrprefixopreg
	instead of addrprefixop0.

opcodes/

	* i386-gen.c (opcode_modifiers): Replace AddrPrefixOp0 with
	AddrPrefixOpReg.
	* i386-opc.h (AddrPrefixOp0): Renamed to ...
	(AddrPrefixOpReg): This.
	(i386_opcode_modifier): Rename addrprefixop0 to addrprefixopreg.
	* i386-opc.tbl: Replace AddrPrefixOp0 with AddrPrefixOpReg.



More information about the Gdb-testers mailing list