[binutils-gdb] C++ify fileio_fh_t, replace VEC with std::vector
sergiodj+buildbot@sergiodj.net
sergiodj+buildbot@sergiodj.net
Wed Apr 11 10:58:00 GMT 2018
*** TEST RESULTS FOR COMMIT 5ff79300aef4f4c991194541ec3ad9a2618ff24c ***
Author: Pedro Alves <palves@redhat.com>
Branch: master
Commit: 5ff79300aef4f4c991194541ec3ad9a2618ff24c
C++ify fileio_fh_t, replace VEC with std::vector
Preparation for the next patch.
- Replace VEC with std::vector.
- Rewrite a couple macros as methods/functions.
- While at it, rename fileio_fh_t::fd as fileio_fh_t::target_fd to
avoid confusion between target and host file descriptors.
gdb/ChangeLog:
2018-04-11 Pedro Alves <palves@redhat.com>
* target.c (fileio_fh_t): Make it a named struct instead of a
typedef.
(fileio_fh_t::is_closed): New method.
(DEF_VEC_O (fileio_fh_t)): Remove.
(fileio_fhandles): Now a std::vector.
(is_closed_fileio_fh): Delete.
(acquire_fileio_fd): Adjust. Rename parameters.
(release_fileio_fd): Adjust.
(fileio_fd_to_fh): Reimplement as a function instead of a macro.
(target_fileio_pwrite, target_fileio_pread, target_fileio_fstat)
(target_fileio_close): Adjust.
More information about the Gdb-testers
mailing list