[Bug guile/21104] 7.12.1 does not compile with latest guile (2.1.6)

bob at bob131 dot so sourceware-bugzilla@sourceware.org
Sun Nov 24 03:05:00 GMT 2019


https://sourceware.org/bugzilla/show_bug.cgi?id=21104

bob at bob131 dot so changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
                 CC|                            |bob at bob131 dot so

--- Comment #13 from bob at bob131 dot so ---
Would someone be able to review comment #8? I had written a patch of my own
before I noticed that I was beaten to the punch almost two years ago!

(In reply to Anatol Pomozov from comment #11)
> guile commit 9a9e0cceae has made buffer fields private and seems there is no
> non-internal API to manipulate it.

Does this matter? AFAICT, most of the removed API involves stuff that should
have been internal to libguile to start with (managing buffers and cursors,
figuring out when to flush, flushing read buffers when moving to write mode and
vice-versa, etc). The removed API makes it difficult to port
memory-port-read-buffer-size et al, but besides that it should present an
opportunity to simplify the implementation considerably.

-- 
You are receiving this mail because:
You are on the CC list for the bug.


More information about the Gdb-prs mailing list