[Bug testsuite/25059] gcc/g++/gfortran/gnatmake 4.8 FAILs

vries at gcc dot gnu.org sourceware-bugzilla@sourceware.org
Mon Oct 14 21:20:00 GMT 2019


https://sourceware.org/bugzilla/show_bug.cgi?id=25059

--- Comment #3 from Tom de Vries <vries at gcc dot gnu.org> ---
With master and https://sourceware.org/ml/gdb-patches/2019-10/msg00155.html
applied, we have left:
...
FAIL: gdb.base/max-depth.exp: l=c++: exp='v4': depth=2: p v4
FAIL: gdb.base/max-depth.exp: l=c++: exp='v4': depth=3: p v4
FAIL: gdb.base/max-depth.exp: l=c++: exp='v4': depth=unlimited: p v4
FAIL: gdb.base/max-depth.exp: l=c++: exp='v5': depth=2: p v5
FAIL: gdb.base/max-depth.exp: l=c++: exp='v5': depth=3: p v5
FAIL: gdb.base/max-depth.exp: l=c++: exp='v5': depth=unlimited: p v5
FAIL: gdb.base/max-depth.exp: l=c++: exp='v6': depth=2: p v6
FAIL: gdb.base/max-depth.exp: l=c++: exp='v6': depth=3: p v6
FAIL: gdb.base/max-depth.exp: l=c++: exp='v6': depth=unlimited: p v6
FAIL: gdb.base/max-depth.exp: l=c++: exp='v7': depth=3: p v7
FAIL: gdb.base/max-depth.exp: l=c++: exp='v7': depth=4: p v7
FAIL: gdb.base/max-depth.exp: l=c++: exp='v7': depth=unlimited: p v7
FAIL: gdb.cp/filename.exp: print c.includefile[0]
FAIL: gdb.cp/filename.exp: print pc->includefile[0]
FAIL: gdb.cp/filename.exp: print d.includefile()
FAIL: gdb.cp/filename.exp: print pd->includefile()
FAIL: gdb.cp/subtypes.exp: ptype main::Foo
FAIL: gdb.cp/subtypes.exp: ptype main::Bar
FAIL: gdb.cp/subtypes.exp: ptype main::Baz
FAIL: gdb.cp/subtypes.exp: ptype foobar<int>::Foo
FAIL: gdb.cp/subtypes.exp: ptype foobar<int>::Bar
FAIL: gdb.cp/subtypes.exp: ptype foobar<int>::Baz
FAIL: gdb.cp/subtypes.exp: ptype foobar<char>::Foo
FAIL: gdb.cp/subtypes.exp: ptype foobar<char>::Bar
FAIL: gdb.cp/subtypes.exp: ptype foobar<char>::Baz
FAIL: gdb.fortran/ptype-on-functions.exp: ptype some_module::get_number
FAIL: gdb.fortran/ptype-on-functions.exp: ptype some_module::set_number
...

-- 
You are receiving this mail because:
You are on the CC list for the bug.


More information about the Gdb-prs mailing list