[Bug mi/25055] New: breakpoint command output not visible in MI mode

vries at gcc dot gnu.org sourceware-bugzilla@sourceware.org
Wed Oct 2 08:49:00 GMT 2019


https://sourceware.org/bugzilla/show_bug.cgi?id=25055

            Bug ID: 25055
           Summary: breakpoint command output not visible in MI mode
           Product: gdb
           Version: 8.0.1
            Status: NEW
          Severity: normal
          Priority: P2
         Component: mi
          Assignee: unassigned at sourceware dot org
          Reporter: vries at gcc dot gnu.org
  Target Milestone: ---

[ Since a fix was committed corresponding to a problem report submitted to the
mailing list, filing a corresponding PR here, for ease of reference. ]

https://sourceware.org/ml/gdb/2017-10/msg00020.html:
...
There seems to be a problem with execution of "bt" as part of
breakpoint commands in MI mode: the output of "bt" is not shown.

What I did was invoke GDB as "gdb -i=mi PROGRAM", then set a
breakpoint or a watchpoint in that program, and defined the following
as its breakpoint commands:

  bt
  end

When the breakpoint triggers, I don't see the backtrace.

I tried other commands, like "up" and "print SOME-VARIABLE", and they
do seem to be executed and the output shown.  So why doesn't that
happen with "backtrace"?  Is it a bug or am I missing something?

(FWIW, I also tried using -break-commands, with a similar result: the
backtrace is not shown when the breakpoint triggers.)

This problem prevents "bt" from being useful in breakpoint commands
when running with the Emacs GDB front-end, which uses MI.

Thanks in advance for any pointers.
...

-- 
You are receiving this mail because:
You are on the CC list for the bug.


More information about the Gdb-prs mailing list