[Bug c++/12328] Can't set breakpoint on method taking const, non-reference/pointer scalar parameter

keiths at redhat dot com sourceware-bugzilla@sourceware.org
Fri Dec 17 23:13:00 GMT 2010


http://sourceware.org/bugzilla/show_bug.cgi?id=12328

--- Comment #4 from Keith Seitz <keiths at redhat dot com> 2010-12-17 17:03:34 UTC ---
(In reply to comment #3)
> I have tried g++-3.3, g++-4.3 and g++-4.4 on debian and they all have the
> same error with gdb 7.2.
> When using gdb_7.0.1-2+b1_i386.deb it is working fine and the breakpoint
> can be set.

That's happens because prior to 7.1, GDB used DW_AT_MIPS_linkage_name.
Nowadays, we compute a canonicalized physical name based on the debug
information. MIPS_linkage_name was too unreliable (and often "wrong" for GDB
consumption).

I just built GCC 3.4.6, and it also contains the same bug: the class
declaration and function declaration DIEs contain different types ("int" vs
"const int").

-- 
Configure bugmail: http://sourceware.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.



More information about the Gdb-prs mailing list