gdb/2188: gdb 6.5 -- internal error with "-var-update *" command

Daniel Jacobowitz drow@false.org
Sun Jan 14 14:38:00 GMT 2007


The following reply was made to PR gdb/2188; it has been noted by GNATS.

From: Daniel Jacobowitz <drow@false.org>
To: Greg Watson <g.watson@computer.org>
Cc: Clement Chu <clement.chu@infotech.monash.edu.au>,
	gdb-gnats@sources.redhat.com
Subject: Re: gdb/2188: gdb 6.5 -- internal error with "-var-update *" command
Date: Sun, 14 Jan 2007 09:30:00 -0500

 On Sat, Jan 13, 2007 at 10:36:42PM -0700, Greg Watson wrote:
 > Daniel,
 > 
 > CVS doesn't build on FC6. I get a whole lot of warnings like "p- 
 > valprint.c: warning: 'tmp_objstack.alloc_failed' may be used  
 > uninitialized" which cause the build to fail. However I did manage to  
 > build one of the 6.6 snapshots. Using this version I no longer see  
 > the assertion for the argc issue, so it appears to have been fixed in  
 > the later release.
 
 Use --disable-werror to get this to build.  There was a discussion
 about those warnings, but it never resolved, unfortunately.
 
 -- 
 Daniel Jacobowitz
 CodeSourcery



More information about the Gdb-prs mailing list