gdb/2171: No backtrace generated on amd64 [SOLVED]

Joe Hansche madcoder@gmail.com
Mon Sep 18 23:38:00 GMT 2006


The following reply was made to PR gdb/2171; it has been noted by GNATS.

From: "Joe Hansche" <madcoder@gmail.com>
To: "Daniel Jacobowitz" <drow@false.org>
Cc: gdb-gnats@sources.redhat.com
Subject: Re: gdb/2171: No backtrace generated on amd64 [SOLVED]
Date: Mon, 18 Sep 2006 17:32:36 -0600

 Yep, that was it, thanks!  Turns out gentoo included those pie patches
 up through version 6.3, then for some reason, the patches are no
 longer included.  I downgraded gdb to 6.3, and it works fine.
 
 Thanks again for all your help.
 Joe
 
 On 9/18/06, Daniel Jacobowitz <drow@false.org> wrote:
 > On Mon, Sep 18, 2006 at 06:21:40AM -0600, Joe Hansche wrote:
 > > I've upgraded to kernel version 2.6.17, with the same results (after
 > > recompiling both gdb and php).  I tried looking through the kernel
 > > .config to see what might cause something like this.  The only thing I
 > > ended up changing, aside from the defaults in the new kernel, was
 > > changing the memory model from Discontiguous to Sparse.
 > >
 > > Any more ideas?  Or since you are saying it looks like a kernel
 > > problem, where should I look for more information on this?
 >
 > drow@caradoc:~/nevyn-home/z% readelf -l php | head
 >
 > Elf file type is DYN (Shared object file)
 >
 > There we go.  This is PIE, a position independent executable.  The FSF
 > GDB does not support PIE.
 >
 > I believe Red Hat ships some unsubmitted patches for this issue; they
 > were mentioned on the gdb mailing list a few weeks ago.
 >
 > --
 > Daniel Jacobowitz
 > CodeSourcery
 >



More information about the Gdb-prs mailing list