gdb/2034: gdb does not compile with gcc-4.0

Daniel Jacobowitz drow@false.org
Sat Nov 19 06:48:00 GMT 2005


The following reply was made to PR gdb/2034; it has been noted by GNATS.

From: Daniel Jacobowitz <drow@false.org>
To: Steven Scholz <steven.scholz@imc-berlin.de>
Cc: gdb-gnats@sources.redhat.com
Subject: Re: gdb/2034: gdb does not compile with gcc-4.0
Date: Sat, 19 Nov 2005 01:39:02 -0500

 On Thu, Nov 17, 2005 at 08:58:41AM +0100, Steven Scholz wrote:
 > Daniel Jacobowitz wrote:
 > > On Wed, Nov 16, 2005 at 01:59:37PM -0000, steven.scholz@imc-berlin.de wrote:
 > > 
 > >>gdb does not compile with gcc-4.0.
 > >>GCC 4 is picky about "lvalue in assignment".
 > >>
 > >>For instance:
 > >>
 > >>gdb-6.3/sim/arm/iwmmxt.c: In function 'WMAC': gdb-6.3/sim/arm/iwmmxt.c:2117: error: invalid lvalue in assignment gdb-6.3/sim/arm/iwmmxt.c:2133: error: invalid lvalue in assignment
 > > 
 > 
 > Thanks for your reply!
 > 
 > 
 > > This is fixed in GDB 6.4, to be released soon.  There will not be
 > > another release of GDB 6.3.
 > 
 > Are these changes in the current CVS?
 
 Yes, they are (both HEAD and 6.4 branch).
 
 -- 
 Daniel Jacobowitz
 CodeSourcery, LLC



More information about the Gdb-prs mailing list