gdb/2034: gdb does not compile with gcc-4.0

steven.scholz@imc-berlin.de steven.scholz@imc-berlin.de
Wed Nov 16 14:08:00 GMT 2005


>Number:         2034
>Category:       gdb
>Synopsis:       gdb does not compile with gcc-4.0
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    unassigned
>State:          open
>Class:          change-request
>Submitter-Id:   net
>Arrival-Date:   Wed Nov 16 14:08:01 GMT 2005
>Closed-Date:
>Last-Modified:
>Originator:     steven.scholz@imc-berlin.de
>Release:        gdb-6.3
>Organization:
>Environment:
gcc (GCC) 4.0.2 20050901 (prerelease) (SUSE Linux)
SuSE 10.0
>Description:
gdb does not compile with gcc-4.0.
GCC 4 is picky about "lvalue in assignment".

For instance:

gdb-6.3/sim/arm/iwmmxt.c: In function 'WMAC': gdb-6.3/sim/arm/iwmmxt.c:2117: error: invalid lvalue in assignment gdb-6.3/sim/arm/iwmmxt.c:2133: error: invalid lvalue in assignment

Thanks,

Steven

>How-To-Repeat:

>Fix:

>Release-Note:
>Audit-Trail:
>Unformatted:



More information about the Gdb-prs mailing list