[PATCH] Fix some comments in dwarf2/cooked-index.h

Tom de Vries tdevries@suse.de
Sat Sep 7 01:52:03 GMT 2024


On 9/6/24 19:55, Tom Tromey wrote:
> This fixes a couple of comments in dwarf2/cooked-index.h.
> 
> The comment by cooked_index_entry::canonical mentions C++, but this
> field can also be different from 'name' in other situations.  Rather
> than enumerate the cases here (which doesn't seem important), make the
> text a little less specific.
> 
> Also, cooked_index_entry::write_scope doesn't document its "for_main"
> parameter -- and it is misnamed in the prototype as well.

Hi,

LGTM.

Reviewed-By: Tom de Vries <tdevries@suse.de>

Thanks,
- Tom

> ---
>   gdb/dwarf2/cooked-index.h | 8 ++++----
>   1 file changed, 4 insertions(+), 4 deletions(-)
> 
> diff --git a/gdb/dwarf2/cooked-index.h b/gdb/dwarf2/cooked-index.h
> index e9f13c97be0..0e63edae1c4 100644
> --- a/gdb/dwarf2/cooked-index.h
> +++ b/gdb/dwarf2/cooked-index.h
> @@ -227,8 +227,7 @@ struct cooked_index_entry : public allocate_on_obstack<cooked_index_entry>
>        linkage name -- two entries are created for DIEs which have both
>        attributes.  */
>     const char *name;
> -  /* The canonical name.  For C++ names, this may differ from NAME.
> -     In all other cases, this is equal to NAME.  */
> +  /* The canonical name.  This may be equal to NAME.  */
>     const char *canonical = nullptr;
>     /* The DWARF tag.  */
>     enum dwarf_tag tag;
> @@ -245,9 +244,10 @@ struct cooked_index_entry : public allocate_on_obstack<cooked_index_entry>
>   
>     /* A helper method for full_name.  Emits the full scope of this
>        object, followed by the separator, to STORAGE.  If this entry has
> -     a parent, its write_scope method is called first.  */
> +     a parent, its write_scope method is called first.  FOR_MAIN is
> +     true when computing the name of 'main'; see full_name.  */
>     void write_scope (struct obstack *storage, const char *sep,
> -		    bool for_name) const;
> +		    bool for_main) const;
>   
>     /* The parent entry.  This is NULL for top-level entries.
>        Otherwise, it points to the parent entry, such as a namespace or



More information about the Gdb-patches mailing list