[PATCH] sim: common: rename sim_print_config
Andrew Burgess
andrew.burgess@embecosm.com
Mon Jan 4 11:04:39 GMT 2021
* Mike Frysinger via Gdb-patches <gdb-patches@sourceware.org> [2021-01-03 02:33:49 -0500]:
> print_sim_config has never been used anywhere, so rename it to follow
> the sim_* naming style for all other symbols we export.
> ---
> sim/common/sim-config.c | 2 +-
> sim/common/sim-config.h | 2 +-
> 2 files changed, 2 insertions(+), 2 deletions(-)
>
> sim/common/:
>
> * sim-config.c (print_sim_config): Rename to ...
> (sim_config_print): ... this.
> * sim-config.h: Likewise.
LGTM.
Thanks,
Andrew
>
> diff --git a/sim/common/sim-config.c b/sim/common/sim-config.c
> index ba3e372c1592..2acd1e4f77af 100644
> --- a/sim/common/sim-config.c
> +++ b/sim/common/sim-config.c
> @@ -294,7 +294,7 @@ sim_config (SIM_DESC sd)
>
>
> void
> -print_sim_config (SIM_DESC sd)
> +sim_config_print (SIM_DESC sd)
> {
> sim_io_printf (sd, "WITH_TARGET_BYTE_ORDER = %s\n",
> config_byte_order_to_a (WITH_TARGET_BYTE_ORDER));
> diff --git a/sim/common/sim-config.h b/sim/common/sim-config.h
> index 8e70bc8210b5..6ab8d1a97eca 100644
> --- a/sim/common/sim-config.h
> +++ b/sim/common/sim-config.h
> @@ -313,7 +313,7 @@ extern SIM_RC sim_config (SIM_DESC sd);
>
> /* Print the simulator configuration. */
>
> -extern void print_sim_config (SIM_DESC sd);
> +extern void sim_config_print (SIM_DESC sd);
>
>
> #endif
> --
> 2.28.0
>
More information about the Gdb-patches
mailing list