[PP?] [PATCH v2 12/16] Change remove_target_sections to method on program_space

Simon Marchi simark@simark.ca
Tue Oct 20 14:40:49 GMT 2020


On 2020-10-19 5:44 p.m., Tom Tromey wrote:
> This changes remove_target_sections to be a method on program_space.
> This makes sense because this function manipulates data that is
> attached to the program space.
>
> gdb/ChangeLog
> 2020-10-19  Tom Tromey  <tom@tromey.com>
>
> 	* progspace.h (struct program_space) <remove_target_sections>:
> 	Declare.
> 	* exec.c (program_space::remove_target_sections): Now a method.
> 	* exec.h (remove_target_sections): Don't declare.
> ---
>  gdb/ChangeLog   |  7 +++++++
>  gdb/exec.c      | 15 ++++++---------
>  gdb/exec.h      |  4 ----
>  gdb/progspace.h |  3 +++
>  gdb/solib.c     |  6 +++---
>  gdb/symfile.c   |  2 +-
>  6 files changed, 20 insertions(+), 17 deletions(-)
>
> diff --git a/gdb/exec.c b/gdb/exec.c
> index 4a82b38ea41..8952a99bf1a 100644
> --- a/gdb/exec.c
> +++ b/gdb/exec.c
> @@ -651,31 +651,28 @@ add_target_sections_of_objfile (struct objfile *objfile)
>     OWNER must be the same value passed to add_target_sections.  */
>
>  void
> -remove_target_sections (void *owner)
> +program_space::remove_target_sections (void *owner)

Would it make sense to make a subsequent patch that just moves this
method to progspace.c?  I think it's ok to leave it in exec.c in this
patch, so we can more easily see the diff, but I think in the end it
belongs to progspace.c.

The only thing that doesn't belong to progspace.c in this method is:

  unpush_target (&exec_ops);

But I think it just means that we need better decoupling.  We could have
a "program_space_target_sections_changed" observer, which exec.c would
attach to, and push/unpush as necessary.

>  {
> -  target_section_table *table = &current_program_space->target_sections;
> -
>    gdb_assert (owner != NULL);
>
> -  auto it = std::remove_if (table->begin (),
> -			    table->end (),
> +  auto it = std::remove_if (target_sections.begin (),
> +			    target_sections.end (),
>  			    [&] (target_section &sect)
>  			    {
>  			      return sect.owner == owner;
>  			    });
> -  table->erase (it, table->end ());
> +  target_sections.erase (it, target_sections.end ());
>
>    /* If we don't have any more sections to read memory from,
>       remove the file_stratum target from the stack of each
>       inferior sharing the program space.  */
> -  if (table->empty ())
> +  if (target_sections.empty ())
>      {
>        scoped_restore_current_pspace_and_thread restore_pspace_thread;
> -      program_space *curr_pspace = current_program_space;
>
>        for (inferior *inf : all_inferiors ())
>  	{
> -	  if (inf->pspace != curr_pspace)
> +	  if (inf->pspace != this)
>  	    continue;
>
>  	  if (!inf->pspace->target_sections.empty ())

This line can be simplified, I believe:

  if (!this->target_sections.empty ())

(you can omit `this` to be consistent with the rest of the code, I just
happen to like using `this` to access fields that aren't prefixed with
`m_`, for clarity)

Simon


More information about the Gdb-patches mailing list