[PATCH] Add NetBSD/aarch64 gdbserver support

Kamil Rytarowski n54@gmx.com
Tue Oct 6 15:44:02 GMT 2020


On 06.10.2020 16:27, Luis Machado wrote:
> Hi,
> 
> On 10/5/20 9:01 PM, Kamil Rytarowski wrote:
>> The support is on par with NetBSD/amd64, thus GPR works,
>> single step and software breakpoint are operational, and the
>> SVR4 r_debug integration is functional.
>>
>> gdbserver/ChangeLog:
>>
>>          * netbsd-aarch64-low.cc: Add.
>>          * Makefile.in (SFILES): Register "netbsd-aarch64-low.c".
>>          * configure.srv: Add aarch64*-*-netbsd*.
>> ---
>>   gdbserver/ChangeLog             |   6 ++
>>   gdbserver/Makefile.in           |   1 +
>>   gdbserver/configure.srv         |   6 ++
>>   gdbserver/netbsd-aarch64-low.cc | 113 ++++++++++++++++++++++++++++++++
>>   4 files changed, 126 insertions(+)
>>   create mode 100644 gdbserver/netbsd-aarch64-low.cc
>>
>> diff --git a/gdbserver/ChangeLog b/gdbserver/ChangeLog
>> index d667a203e67..5fd71b6ee71 100644
>> --- a/gdbserver/ChangeLog
>> +++ b/gdbserver/ChangeLog
>> @@ -1,3 +1,9 @@
>> +2020-10-01  Kamil Rytarowski  <n54@gmx.com>
>> +
>> +    * netbsd-aarch64-low.cc: Add.
>> +    * Makefile.in (SFILES): Register "netbsd-aarch64-low.c".
>> +    * configure.srv: Add aarch64*-*-netbsd*.
>> +
>>   2020-10-01  Kamil Rytarowski  <n54@gmx.com>
>>
>>       * netbsd-i386-low.cc: Add.
>> diff --git a/gdbserver/Makefile.in b/gdbserver/Makefile.in
>> index 8b80acebdf1..442a34b381f 100644
>> --- a/gdbserver/Makefile.in
>> +++ b/gdbserver/Makefile.in
>> @@ -193,6 +193,7 @@ SFILES = \
>>       $(srcdir)/linux-x86-low.cc \
>>       $(srcdir)/linux-xtensa-low.cc \
>>       $(srcdir)/mem-break.cc \
>> +    $(srcdir)/netbsd-aarch64-low.cc \
>>       $(srcdir)/netbsd-amd64-low.cc \
>>       $(srcdir)/netbsd-i386-low.cc \
>>       $(srcdir)/netbsd-low.cc \
>> diff --git a/gdbserver/configure.srv b/gdbserver/configure.srv
>> index c4fe4ca81ee..cd25b1574e0 100644
>> --- a/gdbserver/configure.srv
>> +++ b/gdbserver/configure.srv
>> @@ -61,6 +61,12 @@ case "${gdbserver_host}" in
>>               ipa_obj="${ipa_obj} linux-aarch64-tdesc-ipa.o"
>>               ipa_obj="${ipa_obj} arch/aarch64-ipa.o"
>>               ;;
>> +  aarch64*-*-netbsd*)    srv_regobj=""
>> +            srv_tgtobj="netbsd-low.o netbsd-aarch64-low.o fork-child.o"
>> +            srv_tgtobj="${srv_tgtobj} nat/fork-inferior.o"
>> +            srv_tgtobj="${srv_tgtobj} nat/netbsd-nat.o"
>> +            srv_tgtobj="${srv_tgtobj} arch/aarch64-insn.o
>> arch/aarch64.o"
>> +            ;;
>>     arm*-*-linux*)    srv_tgtobj="$srv_linux_obj linux-arm-low.o"
>>               srv_tgtobj="$srv_tgtobj linux-arm-tdesc.o"
>>               srv_tgtobj="$srv_tgtobj linux-aarch32-low.o"
>> diff --git a/gdbserver/netbsd-aarch64-low.cc
>> b/gdbserver/netbsd-aarch64-low.cc
>> new file mode 100644
>> index 00000000000..d0e485649d9
>> --- /dev/null
>> +++ b/gdbserver/netbsd-aarch64-low.cc
>> @@ -0,0 +1,113 @@
>> +/* Copyright (C) 2020 Free Software Foundation, Inc.
>> +
>> +   This file is part of GDB.
>> +
>> +   This program is free software; you can redistribute it and/or modify
>> +   it under the terms of the GNU General Public License as published by
>> +   the Free Software Foundation; either version 3 of the License, or
>> +   (at your option) any later version.
>> +
>> +   This program is distributed in the hope that it will be useful,
>> +   but WITHOUT ANY WARRANTY; without even the implied warranty of
>> +   MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
>> +   GNU General Public License for more details.
>> +
>> +   You should have received a copy of the GNU General Public License
>> +   along with this program.  If not, see
>> <http://www.gnu.org/licenses/>.  */
>> +
>> +#include <sys/types.h>
>> +#include <sys/ptrace.h>
>> +#include <limits.h>
>> +
>> +#include "server.h"
>> +#include "netbsd-low.h"
>> +#include "arch/aarch64.h"
>> +#include "arch/aarch64-insn.h"
>> +#include "tdesc.h"
>> +
>> +/* The fill_function for the general-purpose register set.  */
>> +
>> +static void
>> +netbsd_aarch64_fill_gregset (struct regcache *regcache, char *buf)
>> +{
>> +  struct reg *r = (struct reg *) buf;
>> +
>> +#define netbsd_aarch64_collect_gp(regnum, fld) do {        \
>> +    collect_register (regcache, regnum, &r->fld);        \
>> +  } while (0)
> 
> Do we really need the above instead of using the for loop below?
> 

This macro is used for consistency with other supported CPU
architectures in gdbserver. I don't want to diverge them in style.

>> +
>> +  for (size_t i = 0; i < 31; i++)
>> +    netbsd_aarch64_collect_gp (AARCH64_X0_REGNUM + i, r_reg[i]);
> 
> A matter of taste, but we could define a reasonably-named constant for
> "31" instead of hardcoding it here.
> 

I will change this hardcode magic value to ARRAY_SIZE() or similar.

>> +
>> +  netbsd_aarch64_collect_gp (AARCH64_SP_REGNUM, r_sp);
>> +  netbsd_aarch64_collect_gp (AARCH64_PC_REGNUM, r_pc);
>> +}
>> +
>> +/* The store_function for the general-purpose register set.  */
>> +
>> +static void
>> +netbsd_aarch64_store_gregset (struct regcache *regcache, const char
>> *buf)
>> +{
>> +  struct reg *r = (struct reg *) buf;
>> +
>> +#define netbsd_aarch64_supply_gp(regnum, fld) do {        \
>> +    supply_register (regcache, regnum, &r->fld);        \
>> +  } while(0)
> 
> Same as above. Do we really need this construct?
> 

Same here, for the consistency.

>> +
>> +  for (size_t i = 0; i < 31; i++)
>> +    netbsd_aarch64_supply_gp (AARCH64_X0_REGNUM + i, r_reg[i]);
> 
> Same suggestion to replace the hardcoded constant with a define.
> 

I will do it.

>> +
>> +  netbsd_aarch64_supply_gp (AARCH64_SP_REGNUM, r_sp);
>> +  netbsd_aarch64_supply_gp (AARCH64_PC_REGNUM, r_pc);
>> +}
>> +
>> +/* Description of all the aarch64-netbsd register sets.  */
>> +
>> +static const struct netbsd_regset_info netbsd_target_regsets[] =
>> +{
>> +  /* General Purpose Registers.  */
>> +  {PT_GETREGS, PT_SETREGS, sizeof (struct reg),
>> +  netbsd_aarch64_fill_gregset, netbsd_aarch64_store_gregset},
>> +  /* End of list marker.  */
>> +  {0, 0, -1, NULL, NULL }
>> +};
>> +
>> +/* NetBSD target op definitions for the aarch64 architecture.  */
>> +
>> +class netbsd_aarch64_target : public netbsd_process_target
>> +{
>> +protected:
>> +  const netbsd_regset_info *get_regs_info () override;
>> +
>> +  void low_arch_setup () override;
>> +};
>> +
>> +/* Return the information to access registers.  */
>> +
>> +const netbsd_regset_info *
>> +netbsd_aarch64_target::get_regs_info ()
>> +{
>> +  return netbsd_target_regsets;
>> +}
>> +
>> +/* Architecture-specific setup for the current process.  */
>> +
>> +void
>> +netbsd_aarch64_target::low_arch_setup ()
>> +{
>> +  target_desc *tdesc
>> +    = aarch64_create_target_description (0, false);
> 
> Did you choose to go with the standard core registers with CPSR and no
> TPIDR?
> 

In this minimal version, CPSR and TPIDR are not necessary.

> Otherwise this looks good and I don't have any more comments.

I'm going to submit a v2 of this patch.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 833 bytes
Desc: OpenPGP digital signature
URL: <https://sourceware.org/pipermail/gdb-patches/attachments/20201006/01c52a44/attachment.sig>


More information about the Gdb-patches mailing list