[PP?] Re: [RFC] Change boolean options to bool instead of int

Simon Marchi simark@simark.ca
Mon Sep 16 17:04:00 GMT 2019


On 2019-09-15 7:28 p.m., Andrew Burgess wrote:
>> @@ -842,6 +845,7 @@ captured_main_1 (struct captured_main_args *context)
>>  		   gdb_program_name);
>>  	  }
>>        }
>> +    write_files = write_files_1;
> 
> I would prefer to see conversions from int to bool be made explicit:
> 
>   write_files = (write_files_1 != 0);
> 
> but if you strongly oppose then I don't care that much.

I agree, it goes in line with our rule of explicitly using

  if (some_int != 0)

rather than

  if (some_int)

Simon



More information about the Gdb-patches mailing list