[PATCH 23/23] Multi-target: NEWS and user manual

Pedro Alves palves@redhat.com
Thu Oct 17 02:08:00 GMT 2019


Hi Eli,

On 9/7/19 7:33 AM, Eli Zaretskii wrote:
>> From: Pedro Alves <palves@redhat.com>

>> +@item
>> +the connection name, derived from the protocol used by the connection.
> 
> "Name" sounds ... inaccurate, when it can be something like
> "extended-remote host:10000", doesn't it?  How about "Type"?  Or maybe
> call that "Description" and the last field "Details"?

You're right.  I called it "name" because originally it was really
the target's short name (target_shortname).  When I got to supporting
multiple remote connections, I figured that we'd want to see
the arguments that were passed to "target remote", but did not think
to rename the column.

How about calling it "what", like so:

(gdb) info connections 
  Num  What          Description       
  1    remote :9999  Remote serial target in gdb-specific protocol 
  2    native        Native process    
* 3    core          Local core dump file 

Not unlike the "What" column in info breakpoints.

(
It may be a good idea to make "core" show the core file's filename:

(gdb) info connections 
  Num  What            Description       
  1    remote :9999    Remote serial target in gdb-specific protocol 
  2    native          Native process    
* 3    core core.3263  Local core dump file 
  4    core core.7146  Local core dump file 
)

Thanks,
Pedro Alves



More information about the Gdb-patches mailing list