[PATCH v2 2/3] gdb: Rename fputs_unfiltered to ui_file_puts.

Iain Buclaw ibuclaw@gdcproject.org
Fri Nov 29 00:03:00 GMT 2019


This patch redefines fputs_unfiltered in utils.c, with new behavior to forward parameters to fputs_maybe_filtered.  This makes fputs_unfiltered identical to fputs_filtered, except filtering is disabled.

Some callers of fputs_unfiltered have been updated to use ui_file_puts where they were using other ui_file_* functions anyway for IO.

This fixes the problem I saw with \032\032post-prompt annotation being flushed to stdout in the wrong order.

--
Iain

---
gdb/ChangeLog:

2019-11-29  Iain Buclaw  <ibuclaw@gdcproject.org>

        * gdb/remote-sim.c (gdb_os_write_stderr): Update.
        * gdb/remote.c (remote_console_output): Update.
        * gdb/ui-file.c (fputs_unfiltered): Rename to...
        (ui_file_puts): ...this.
        * gdb/ui-file.h (ui_file_puts): Add declaration.
        * gdb/utils.c (emit_style_escape): Update.
        (flush_wrap_buffer): Update.
        (fputs_maybe_filtered): Update.
        (fputs_unfiltered): Add function.

---


-------------- next part --------------
A non-text attachment was scrubbed...
Name: uifileputs.patch
Type: text/x-patch
Size: 3316 bytes
Desc: not available
URL: <http://sourceware.org/pipermail/gdb-patches/attachments/20191129/0a9eb461/attachment.bin>


More information about the Gdb-patches mailing list