[PATCH 13/15] Remove simulator_command declaration, make static

Simon Marchi simon.marchi@efficios.com
Mon Nov 25 05:27:00 GMT 2019


The simulator_command function is not used outside its file, so make it
static.  Remove the declaration, which is not needed and not even in
sync with the definition.

gdb/ChangeLog:

	* remote-sim.c (simulator_command): Make static, remove
	declaration.

Change-Id: I40bd1e3662f849c4c9970443931ab9ee0ccccea1
---
 gdb/remote-sim.c | 4 +---
 1 file changed, 1 insertion(+), 3 deletions(-)

diff --git a/gdb/remote-sim.c b/gdb/remote-sim.c
index 8f86f5d3132e..e49d5d67b5c9 100644
--- a/gdb/remote-sim.c
+++ b/gdb/remote-sim.c
@@ -69,8 +69,6 @@ static void gdb_os_evprintf_filtered (host_callback *, const char *, va_list);
 static void gdb_os_error (host_callback *, const char *, ...)
      ATTRIBUTE_NORETURN;
 
-void simulator_command (char *args, int from_tty);
-
 /* Naming convention:
 
    sim_* are the interface to the simulator (see remote-sim.h).
@@ -1162,7 +1160,7 @@ gdbsim_target::mourn_inferior ()
 /* Pass the command argument through to the simulator verbatim.  The
    simulator must do any command interpretation work.  */
 
-void
+static void
 simulator_command (const char *args, int from_tty)
 {
   struct sim_inferior_data *sim_data;
-- 
2.24.0



More information about the Gdb-patches mailing list