[PATCH 0/2] btrace, gdbserver: allow "record btrace" for running threads

Markus Metzger markus.t.metzger@intel.com
Tue Dec 6 15:55:00 GMT 2016


This refers to:  https://sourceware.org/ml/gdb-patches/2016-11/msg00994.html.

For the remote case I ran into an unexpected gdbserver quit, which is addressed
in the first of the two patches.

I tested this on one 32-bit and one 64-bit Intel Fedora system.  On the former
(4.4.6-301.fc23.i686+PAE), I ran into several PASS/FAIL changes between
different runs in the gdb.threads suite.  When I run those tests a few times, I
get completely different results for almost every run (already without my
changes).  Ignoring those.

Markus Metzger (2):
  gdbserver: catch fetch registers error
  btrace: allow recording to be started for running threads

 gdb/btrace.c                                | 24 +++++++++-
 gdb/gdbserver/linux-low.c                   | 19 +++++++-
 gdb/gdbserver/server.c                      | 18 +++++++-
 gdb/testsuite/gdb.btrace/enable-running.c   | 47 +++++++++++++++++++
 gdb/testsuite/gdb.btrace/enable-running.exp | 72 +++++++++++++++++++++++++++++
 5 files changed, 175 insertions(+), 5 deletions(-)
 create mode 100644 gdb/testsuite/gdb.btrace/enable-running.c
 create mode 100644 gdb/testsuite/gdb.btrace/enable-running.exp

-- 
1.8.3.1



More information about the Gdb-patches mailing list