[PATCH 1/3] Rename some trace functions

Simon Marchi simon.marchi@polymtl.ca
Thu Dec 1 16:07:00 GMT 2016


On 2016-12-01 09:21, Pedro Alves wrote:
>>  static void trace_find_command (char *, int);
>>  static void trace_find_pc_command (char *, int);
>>  static void trace_find_tracepoint_command (char *, int);
> 
> Surprised you didn't do the same to "trace_find" -> "tfind" ?

Hmm indeed.  And trace_dump -> tdump as well.

I'll send a v2, since there's new stuff.

> Meanwhile we have C++11, so we could consider making this
> an "enum class" instead.  Then we could keep using
> tstop_command here.

Indeed.  But for this I think I prefer "trace_stop_command" over 
"tstop_command" anyway.



More information about the Gdb-patches mailing list