[PATCH 2/8] Add new gdbarch method, unconditional_branch_address

Pedro Alves palves@redhat.com
Tue Aug 25 12:13:00 GMT 2015


On 08/19/2015 08:00 AM, Kevin Buettner wrote:

> +# Examine instruction at PC.  If instruction at PC is an unconditional
> +# branch, return the address to which control is transferred when the
> +# branch is taken.  Return 0 when this method is not implemented by
> +# architecture, PC refers to an invalid address, or instruction at PC
> +# is not an unconditional branch.
> +m:CORE_ADDR:unconditional_branch_address:CORE_ADDR pc:pc::default_unconditional_branch_address::0
> +

In addition to the comments in the other patch, I wonder if we would
better name this in terms of a higher level concept, around
"breakpoint address" instead of a "low level branch destination"?

Thanks,
Pedro Alves



More information about the Gdb-patches mailing list