[PATCH] Delete struct inferior_suspend_state

Joel Brobecker brobecker@adacore.com
Thu Jul 31 20:33:00 GMT 2014

> If we're going to keep comments we might as well keep the #if 0'd code
> (which is fine by me).
> There's no real difference between the two, and the #if 0'd out code
> is more descriptive, though I would add a commit (tweak a comment?) so
> that the next person will more easily know that the #if 0's are ok.
> IWBN to have examples where #if 0 is at least not a bad thing.

In my experience, #if 0'ed code has been bit-rotting. Better, IMO,
to just be as descriptive as possible in the code, even if that
involves naming functions, etc. That way, we can maintain the
description a little better.


More information about the Gdb-patches mailing list