[PATCH v2 0/5] mips hardware watchpoint support in gdbserver

Yao Qi yao@codesourcery.com
Mon Jul 22 01:11:00 GMT 2013


On 06/29/2013 11:10 AM, Yao Qi wrote:
> Here is the V2 of this patch series which is to post Jie and Dan's work
> to support mips hardware watchpoint in gdbserver.  There are several
> changes compared with V1:
>
>   - Keep these watchpoint-related structures as the fall back when
> PTRACE_GET_WATCH_REGS is not defined.
>   - Re-org the patch series as Maciej suggested, split the function
> renaming patch out of the function moving patch.
>   - Share 'enum target_hw_bp_type' in GDB and GDBserver, so that a new
> file common/break-common.h is created.
>   - Some typos and code format issues are fixed.
>   - Rename 'debug register' to 'watch register' in comments and code.
>
> Patch 1/5 is to share 'enum target_hw_bp_type' and patch 2/5 is to
> include asm/ptrace.h in mips-linux-nat.c, but keep watchpoint related
> structures as a fall back.  Patch 3/5 is to refactor mips-linux-nat.c,
> rename functions and update comments, etc.  Patch 4/5 is to move mips h/w
> wathcpoint stuff to common, and Patch 5/5 is to support h/w watchpoint
> in gdbserver for MIPS.
>
> The whole series is tested on a MIPS board with only one hardware
> watchpoint register.  I pick this patch up during the test, because
> it fixes an internal error, so this patch series depend on it.
>
>    [RFC] Catch exception after stepped over watchpoint.
>    http://sourceware.org/ml/gdb-patches/2013-06/msg00866.html

Ping.  http://sourceware.org/ml/gdb-patches/2013-06/msg00927.html

-- 
Yao (齐尧)



More information about the Gdb-patches mailing list