[rfc 0/8] refactor record

markus.t.metzger@intel.com markus.t.metzger@intel.com
Thu Feb 14 16:31:00 GMT 2013


From: Markus Metzger <markus.t.metzger@intel.com>

Hi Jan,

Here's an updated version of the record.c refactoring incorporating your
comments and adding two new commands I plan to implement for record-btrace.

The series will not apply to the current master since i'm not resending some
already approved patches.

I tried pushing the entire series into archer but I seem to lack permissions.

I ran the gdb.reverse suite without regressions on 64bit IA gnu/linux.


Markus Metzger (8):
  record: make it build again
  record-full.c: rename record_ in record_full_.
  record-full.h: rename record_ into record_full_
  record: default target methods.
  record: add "record disassemble" command
  record disas: omit function names by default
  record: add "record backtrace" command
  record: add "record list" command

 gdb/Makefile.in        |    5 +-
 gdb/amd64-linux-tdep.c |   53 +-
 gdb/arm-tdep.c         |   12 +-
 gdb/i386-linux-tdep.c  |   30 +-
 gdb/i386-tdep.c        |  465 +++++++-------
 gdb/infrun.c           |    3 +-
 gdb/linux-record.c     |  544 ++++++++-------
 gdb/moxie-tdep.c       |   85 ++--
 gdb/record-full.c      | 1775 ++++++++++++++++++++++++++++--------------------
 gdb/record-full.h      |   10 +-
 gdb/record.c           |  696 ++++++++++++++-----
 gdb/record.h           |   30 +
 gdb/target.c           |  231 +++++++
 gdb/target.h           |   81 +++
 14 files changed, 2505 insertions(+), 1515 deletions(-)



More information about the Gdb-patches mailing list