[RFC] Document replacement for frame_register_read (deprecated).

Tom Tromey tromey@redhat.com
Tue Oct 23 17:19:00 GMT 2012

>>>>> "Joel" == Joel Brobecker <brobecker@adacore.com> writes:

Joel> This is inspired by a discussion from a long time ago:
Joel> http://www.sourceware.org/ml/gdb-patches/2011-03/msg01095.html

Joel> If you agree with the patch, we will also have to update the ARI
Joel> script to mention get_frame_register_value as the alternative.

Joel> And we might also want to rename the function as well. I don't think
Joel> we can rely on the ARI alone to avoid new uses of this function.
Joel> And once new uses are in, it's much harder to make sure we undo them.

Joel> Thoughts?

The patch seems reasonable to me.

Renaming seems like a decent idea, since there is a use in jit.c, which
was added long after this was deprecated.

I count 22 mentions (including the declaration) of frame_register_read
in the tree right now.  Getting rid of all of them doesn't seem so
difficult, aside from the testing.  This would be clearly better...

At least one of the current uses seems suspicious since it ignores the
result.  I assume I'm missing some context though.


More information about the Gdb-patches mailing list