RFC: fix bug in compare_breakpoints

Joel Brobecker brobecker@adacore.com
Fri Oct 19 17:12:00 GMT 2012

> A few are just to stick a comment there, and some others are to work
> around warn_unused_result.

Yeah. In the first case, we could move the comment back to the top,
although perhaps it's easier to read an understand the current way.
I also saw the ones around "warn_unused_result" and we could have
used a cast to (void), I suppose. But in the end, all of this isn't
really all that important. Gives us an opportunity to request a comment
explaining why it's OK to ignore the return value :-).


More information about the Gdb-patches mailing list