[RFA 1/2] mips: Switch inferior function calls to ON_STACK method.

Yao Qi yao@codesourcery.com
Fri May 4 02:11:00 GMT 2012


On 05/04/2012 05:57 AM, Joel Brobecker wrote:
>>> > > +/* Implement the push_dummy_code gdbarch method for mips targets.  */
>> > 
>> > I notice people have been adding this style of comment in some other
>> > newly contributed targets.  Do people really feel that having these is
>> > useful?  If so, can we at least settle on a consitent style?
> I think they are useful, because they allow us to tell people that
> new functions should ALL be documented, even the obvious ones
> that are used to implement a given hook.  And since we do not
> want to repeat the hook's documentation, this tells the reader
> where to look.

Yes, they are useful.  Beyond Joel's description, it still quite useful
when  hook method's comment or parameter is changed, we don't have to
change in every *-tdep.c files.

> 
> I am happy to standardize on any format, as long as we all agree.

+1.

If hook is ABI or target variant specific, such as push_dummy_call in
mips-tdep.c, BAR is the name of ABI or target variant,

  /* Implement the FOO gdbarch method for BAR.  */

If hook is for the whole port, we can simply say this,

  /* Implement the FOO gdbarch method.  */

-- 
Yao (齐尧)



More information about the Gdb-patches mailing list